Uploaded image for project: 'OpenShift Service Mesh'
  1. OpenShift Service Mesh
  2. OSSM-3063

[DOC] Document WasmPlugin with 3Scale adapter

    XMLWordPrintable

Details

    • Story
    • Resolution: Obsolete
    • Major
    • None
    • OSSM 2.2.0
    • None
    • 8
    • False
    • None
    • False
    • Doc sprint 86 (Jan 30-Feb 20)

    Description

      The Service Mesh 3Scale documentation still uses ServiceMeshExtension API, rather than the new WasmPlugin API. Going forward in 2.2, users should use the WasmPlugin API. This should be documented, with:

      • How to move from ServiceMeshExtension to WasmPlugin for users upgrading from 2.1 -> 2.2 (or later)
      • Change guidance for Service Mesh 2.2+ to use WasmPlugin.
      • Move existing ServiceMeshExtension guidance to be 2.0-2.1.

      The urgency on this is increased by the issue https://issues.redhat.com/browse/OSSM-1505, which means that ServiceMeshExtensions will not work with OpenShift 4.11. Thus, the work around until that is fixed is to upgrade to Service Mesh 2.2 and use WasmPlugin rather than ServiceMeshExtensions.

      Ideally, the resolution to this issue (https://issues.redhat.com/browse/OSSMDOC-601) would point to the updated 3Scale docs to explain how to use WasmPlugin with ServiceMeshExtensions.

       

      Related: https://issues.redhat.com/browse/OSSMDOC-551 (could perhaps link here)

      Attachments

        Issue Links

          Activity

            People

              gmonahan Gwynne Monahan
              jlongmui@redhat.com Jamie Longmuir
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: