Uploaded image for project: 'OpenShift Service Mesh'
  1. OpenShift Service Mesh
  2. OSSM-1354

Service Mesh Operator does not set Kiali CR version correctly

    XMLWordPrintable

Details

    • Bug
    • Status: Release Pending
    • Blocker
    • Resolution: Done
    • None
    • OSSM 2.2.0
    • Maistra
    • None
    • Sprint 50

    Description

      When you create an SMCP with version "v2.2" and Kiali is enabled, the Service Mesh Operator will create a Kiali CR. However, when it does so, it creates the wrong "spec.version" field in the Kiali CR. The "spec.version" should be "v1.48". Today it is setting the value to "v1.36", which is the correct value for SMCP v2.1.

      In short, when SMCP is v2.2, the Kiali CR must be created with its spec.version field set to "v1.48".

      Attachments

        Activity

          People

            dgrimm@redhat.com Daniel Grimm
            jmazzitelli John Mazzitelli
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: