Uploaded image for project: 'OpenShift Bugs'
  1. OpenShift Bugs
  2. OCPBUGS-7741

[release-4.11] fail early on missing node status envs

XMLWordPrintable

    • Icon: Bug Bug
    • Resolution: Done
    • Icon: Major Major
    • None
    • 4.11.z
    • Etcd
    • None
    • Moderate
    • No
    • 1
    • ETCD Sprint 232
    • 1
    • Proposed
    • False
    • Hide

      None

      Show
      None

      This is a clone of issue OCPBUGS-7510. The following is the description of the original issue:

      This is a clone of issue OCPBUGS-7373. The following is the description of the original issue:

      Originally reported by lance5890 in issue https://github.com/openshift/cluster-etcd-operator/issues/1000

      Under some circumstances the static pod machinery fails to populate the node status in time to generate the correct env variables for ETCD_URL_HOST, ETCD_NAME etc. The pods that come up will fail to accept those variables.

      This is particularly pronounced in SNO topologies, leading to installation failures. 

      The fix is to fail fast in the targetconfig/envvar controller to ensure the CEO goes degraded instead of silently failing on the rollout of an invalid static pod.

            tjungblu@redhat.com Thomas Jungblut
            openshift-crt-jira-prow OpenShift Prow Bot
            ge liu ge liu
            Votes:
            0 Vote for this issue
            Watchers:
            6 Start watching this issue

              Created:
              Updated:
              Resolved: