Uploaded image for project: 'OpenShift Bugs'
  1. OpenShift Bugs
  2. OCPBUGS-7031

Pipelines repository list and creation form doesn't show Tech Preview status

XMLWordPrintable

    • Informational
    • ODC Sprint 232
    • 1
    • Rejected
    • False
    • Hide

      None

      Show
      None
    • NA

      Description of problem:
      Pipelines Repository support is Tech Preview, this is shown when search for repositories or checking the details page.

      But the tabbed pipelines tab (in admin and dev perspective doesn't show this). Also, the "Add Git Repository" form page doesn't mention this.

      Version-Release number of selected component (if applicable):
      4.11 - 4.13 (master)

      How reproducible:
      Always

      Steps to Reproduce:

      1. Install OpenShift Pipelines operator
      2. Navigate to Pipelines > Repository tab
      3. Select Create > Repository

      Actual results:
      The Repository tab and the "Add Git Repository" form page doesn't show a Tech Preview badge.

      Expected results:
      The Repository tab and the "Add Git Repository" form page should show a Tech Preview badge.

      Additional info:
      Check how the Shipwright Builds show this Tech Preview badge for the tab.

        1. shipwright-builds.png
          shipwright-builds.png
          27 kB
        2. search.png
          search.png
          61 kB
        3. repo-list.png
          repo-list.png
          45 kB
        4. add-git-repo.png
          add-git-repo.png
          26 kB

            rh-ee-lprabhu Lokananda Prabhu
            cjerolim Christoph Jerolimov
            Sanket Pathak Sanket Pathak
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

              Created:
              Updated:
              Resolved: