Uploaded image for project: 'OpenShift Bugs'
  1. OpenShift Bugs
  2. OCPBUGS-34331

geneve port not created for a set of nodes and causing POD to POD connectivity issue

XMLWordPrintable

    • Important
    • No
    • SDN Sprint 254
    • 1
    • False
    • Hide

      None

      Show
      None
    • Customer Escalated
    • 05/23 Workaround on the impacted nodes: pkill -f "/usr/bin/ovnkube --init-ovnkube-controller" -9; case is sev 2. Amadeus; score elevated

      Description of problem:

          Geneve port has not been created for a set of nodes.
      
      ~~~
      [arghosh@supportshell-1 03826869]$ omg get nodes |grep -v NAME|wc -l
      83
      ~~~
      ~~~
      # crictl exec -ti `crictl ps --name nbdb -q` ovn-nbctl show transit_switch | grep tstor-prd-fc-shop09a | wc -l
      73
      # crictl exec -ti `crictl ps --name nbdb -q` ovn-sbctl list chassis | grep -c ^hostname
      41
      # ovs-appctl ofproto/list-tunnels | wc -l
      40
      ~~~

      Version-Release number of selected component (if applicable):

          4.14.17

      How reproducible:

          Not Sure

      Steps to Reproduce:

          1.
          2.
          3.
          

      Actual results:

          POD to POD connectivity issue when PODs are hosted on different nodes

      Expected results:

          POD to POD connectivity should work fine

      Additional info:

          As per customer https://github.com/openshift/ovn-kubernetes/pull/2179 resolves the issue.

            npinaeva@redhat.com Nadia Pinaeva
            rhn-support-arghosh Arnab Ghosh
            Huiran Wang Huiran Wang
            Votes:
            1 Vote for this issue
            Watchers:
            10 Start watching this issue

              Created:
              Updated: