Uploaded image for project: 'OpenShift Bugs'
  1. OpenShift Bugs
  2. OCPBUGS-33682

The setting of NTO cloud provider doesn't work

XMLWordPrintable

    • Icon: Bug Bug
    • Resolution: Unresolved
    • Icon: Major Major
    • 4.16.0
    • 4.16
    • Node Tuning Operator
    • None
    • Moderate
    • Yes
    • False
    • Hide

      None

      Show
      None
    • Release Note Not Required
    • In Progress

      Description of problem:

      The cloud provider feature of NTO doesn't work as expected

      Version-Release number of selected component (if applicable):

          

      How reproducible:

          

      Steps to Reproduce:

          1. Create a cloud-provider profile like as 
      apiVersion: tuned.openshift.io/v1
      kind: Tuned
      metadata:
        name: provider-aws
        namespace: openshift-cluster-node-tuning-operator
      spec:
        profile:
        - data: |
            [main]
            summary=GCE Cloud provider-specific profile
            # Your tuning for GCE Cloud provider goes here.
            [sysctl]
            vm.admin_reserve_kbytes=16386
          name: provider-aws     2.
          3.
          

      Actual results:

          the value of vm.admin_reserve_kbytes still using default value

      Expected results:

          the value of vm.admin_reserve_kbytes should change to 16386

      Additional info:

          

            jmencak Jiri Mencak
            rhn-support-liqcui Liquan Cui
            Liquan Cui Liquan Cui
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

              Created:
              Updated: