Uploaded image for project: 'OpenShift Bugs'
  1. OpenShift Bugs
  2. OCPBUGS-3188

Fail to deprovision cluster on 4.10 and below when swift speaks HTTP2

XMLWordPrintable

    • +
    • Rejected
    • False
    • Hide

      None

      Show
      None

      Description of problem:

      We're seeing CI fail to deprovision the cluster on OpenStack.

      Deprovisioning cluster ...
      /tmp/secret/metadata.json
      Copying the installation artifacts to the Installer's asset directory...
      Running the Installer's 'destroy cluster' command...
      level=error msg=Cannot extract names from response with content-type: []
      level=error msg=Cannot extract names from response with content-type: []
      level=error msg=Cannot extract names from response with content-type: []
      level=error msg=Cannot extract names from response with content-type: []
      level=error msg=Cannot extract names from response with content-type: []
      level=error msg=Cannot extract names from response with content-type: []
      level=error msg=Cannot extract names from response with content-type: []
      level=error msg=Cannot extract names from response with content-type: []
      level=error msg=Cannot extract names from response with content-type: []
      level=error msg=Cannot extract names from response with content-type: []
      level=error msg=Cannot extract names from response with content-type: []
      level=error msg=Cannot extract names from response with content-type: []
      level=error msg=Cannot extract names from response with content-type: []
      level=error msg=Cannot extract names from response with content-type: []
      level=error msg=Cannot extract names from response with content-type: []
      level=error msg=Cannot extract names from response with content-type: []
      level=error msg=Cannot extract names from response with content-type: []
      {"component":"entrypoint","file":"k8s.io/test-infra/prow/entrypoint/run.go:164","func":"k8s.io/test-infra/prow/entrypoint.Options.ExecuteProcess","level":"error","msg":"Process did not finish before 1h0m0s timeout","severity":"error","time":"2022-10-23T16:40:20Z"}
      Copying the Installer logs to the artifacts directory...
      {"component":"entrypoint","file":"k8s.io/test-infra/prow/entrypoint/run.go:254","func":"k8s.io/test-infra/prow/entrypoint.gracefullyTerminate","level":"error","msg":"Process did not exit before 10m0s grace period","severity":"error","time":"2022-10-23T16:50:20Z"}
      {"component":"entrypoint","error":"os: process already finished","file":"k8s.io/test-infra/prow/entrypoint/run.go:256","func":"k8s.io/test-infra/prow/entrypoint.gracefullyTerminate","level":"error","msg":"Could not kill process after grace period","severity":"error","time":"2022-10-23T16:50:20Z"}
       

      A quick search shows this only affects OpenStack clusters, for OCP versions <= 4.10:
      https://search.ci.openshift.org/?search=Cannot+extract+names+from+response+with+content-type&maxAge=48h&context=1&type=bug%2Bissue%2Bjunit&name=&excludeName=&maxMatches=5&maxBytes=20971520&groupBy=job

      Version-Release number of selected component (if applicable):

      4.7 to 4.10
      

      How reproducible:

      Always? To be confirmed. It seems to have started happening sometime in Aug.
       

      Steps to Reproduce:

      1.
      2.
      3.
      

      Actual results:

       

      Expected results:

       

      Additional info:

       

            maandre@redhat.com Martin André
            maandre@redhat.com Martin André
            Jon Uriarte Jon Uriarte
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Created:
              Updated:
              Resolved: