Uploaded image for project: 'OpenShift Bugs'
  1. OpenShift Bugs
  2. OCPBUGS-29084

Installation fails with Dualstack when using provider network and external Loadbalancer

    XMLWordPrintable

Details

    • ?
    • Critical
    • No
    • ShiftStack Sprint 249
    • 1
    • Rejected
    • False
    • Hide

      None

      Show
      None
    • None

    Description

      Description of problem:

          When installing a setup with dualstack provider network and using external Load Balancer for API and Ingress IPs the installation fails:
      
      						ERROR                                                                                                                  ERROR Error: Invalid index                          ERROR                                               ERROR   on private-network.tf line 107, in resource "openstack_networking_port_secgroup_associate_v2" "api_port_sg": ERROR  107:   port_id            = data.openstack_networking_port_ids_v2.api_ports.ids[0]                            ERROR     ├────────────────                                                                                            ERROR     │ data.openstack_networking_port_ids_v2.api_ports.ids is empty list of string ERROR                                                                                                                  ERROR The given key does not identify an element in this collection value: the ERROR collection has no elements.                  ERROR                                               ERROR Error: Invalid index                          ERROR                                               ERROR   on private-network.tf line 114, in resource "openstack_networking_port_secgroup_associate_v2" "ingress_port_sg": ERROR  114:   port_id            = data.openstack_networking_port_ids_v2.ingress_ports.ids[0] ERROR     ├────────────────                         ERROR     │ data.openstack_networking_port_ids_v2.ingress_ports.ids is empty list of string ERROR                                               RROR The given key does not identify an element in this collection value: the                                         ERROR collection has no elements.                                                                                      ERROR failed to fetch Cluster: failed to generate asset "Cluster": failed to create cluster: failure applying terraform for "masters" stage: error applying Terraform configs: failed to apply Terraform: exit status 1 ERROR                   
      					

      Version-Release number of selected component (if applicable):

       4.15.0-0.nightly-2024-02-06-040314

      How reproducible:

          

      Steps to Reproduce:

          1.
          2.
          3.
          

      Actual results:

          

      Expected results:

          

      Additional info:

          

      Attachments

        Issue Links

          Activity

            People

              mdemaced Maysa De Macedo Souza
              itbrown@redhat.com Itshak Brown
              Itshak Brown Itshak Brown
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated: