Uploaded image for project: 'OpenShift Bugs'
  1. OpenShift Bugs
  2. OCPBUGS-28778

Whereabouts reconciler errors with "IPPool not found" on pod deletion although the IPPool exists

    XMLWordPrintable

Details

    • Bug
    • Resolution: Done
    • Critical
    • 4.15.0
    • 4.12
    • Networking / multus
    • None
    • Important
    • No
    • False
    • Hide

      None

      Show
      None

    Description

      This is a clone of issue OCPBUGS-23199. The following is the description of the original issue:

      Description of problem:

      During a pod deletion, the whereabouts reconciler correctly detects the pod deletion but it errors out claiming that the IPPool is not found.However, when checking the audit logs, we can see no deletion, no re-creation and we can even see successful "patch" and "get" requests to the same IPPool. This means that the IPPool was never deleted and properly accessible at the time of the issue, so the error in the reconciler looks like it made some mistake while retrieving the IPPool.

      Version-Release number of selected component (if applicable):

      4.12.22

      How reproducible:

      Sometimes    

      Steps to Reproduce:

          1.Delete pod
          2.
          3.
          

      Actual results:

      Error in whereabouts reconciler. New pods cannot using additional networks with whereabouts IPAM plugin cannot have IPs allocated due to wrong cleanup. 

      Expected results:

          

      Additional info:

          

      Attachments

        Issue Links

          Activity

            People

              zshi@redhat.com Zenghui Shi
              openshift-crt-jira-prow OpenShift Prow Bot
              Weibin Liang Weibin Liang
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: