Uploaded image for project: 'OpenShift Bugs'
  1. OpenShift Bugs
  2. OCPBUGS-28540

Should contain oc.rhel8 for 4.16 ocp payload

XMLWordPrintable

    • Important
    • No
    • Rejected
    • False
    • Hide

      None

      Show
      None
    • Hide
      --- update ---
      Added by PR #77748

      default oc is built on RHEL9 as default and this oc will not work on RHEL8, if FIPS is enabled in that cluster. In order to provide customers whose still rely on RHEL8, we have to provide compatible oc and this issue is to track this.
      Show
      --- update --- Added by PR #77748 default oc is built on RHEL9 as default and this oc will not work on RHEL8, if FIPS is enabled in that cluster. In order to provide customers whose still rely on RHEL8, we have to provide compatible oc and this issue is to track this.
    • Bug Fix
    • Done

      Description of problem:

      Now for 4.16 ocp payload , only contain the oc.rhel9 , can't find the oc.rhel8. 
      oc adm release extract --command='oc.rhel8'  registry.ci.openshift.org/ocp/release:4.16.0-0.nightly-2024-01-24-133352 --command-os=linux/amd64  -a tmp/config.json --to octest/
      error: image did not contain usr/share/openshift/linux_amd64/oc.rhel8

      Version-Release number of selected component (if applicable):

          4.16

      How reproducible:

      always    

      Steps to Reproduce:

          1.oc adm release extract --command='oc.rhel8'  registry.ci.openshift.org/ocp/release:4.16.0-0.nightly-2024-01-24-133352 --command-os=linux/amd64  -a tmp/config.json --to octest/
          2.
          3.
          

      Actual results:

       failed to extract oc.rhel8   

      Expected results:

       for ocp paypload should contain the oc.rhel8. 

      Additional info:

          

            aguclu@redhat.com Arda Guclu
            yinzhou@redhat.com ying zhou
            ying zhou ying zhou
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

              Created:
              Updated:
              Resolved: