Uploaded image for project: 'OpenShift Bugs'
  1. OpenShift Bugs
  2. OCPBUGS-26025

oc command fails to execute occasionally in some CI jobs

XMLWordPrintable

    • No
    • OCPNODE Sprint 247 (Blue), OCPNODE Sprint 248 (Blue)
    • 2
    • False
    • Hide

      None

      Show
      None

      Description of problem:

      The job [sig-node] [Conformance] Prevent openshift node labeling on update by the node TestOpenshiftNodeLabeling [Suite:openshift/conformance/parallel/minimal] uses `oc debug` command [1]. Occasionally we find that command fails to run with ends up failing the test. 

       

      Failing job example - https://prow.ci.openshift.org/view/gs/origin-ci-test/pr-logs/pull/openshift_cluster-monitoring-operator/2220/pull-ci-openshift-cluster-monitoring-operator-master-e2e-aws-ovn-single-node/1742564553356480512

       

      CI search results - https://search.ci.openshift.org/?search=TestOpenshiftNodeLabeling&maxAge=48h&context=1&type=bug%2Bissue%2Bjunit&name=&excludeName=&maxMatches=5&maxBytes=20971520&groupBy=job

       

      [1] https://github.com/openshift/origin/pull/28296/files#diff-001ed6507a42a0a1689e86c05512e6186c3483488ec96bf5f4354a8f7fa79261R39

       

       

      Version-Release number of selected component (if applicable):

       

      How reproducible:

      Observed in CI jobs mentioned above. 

      Steps to Reproduce:

          1.
          2.
          3.
          

      Actual results:

         oc debug command occasionally exits with error 

      Expected results:

          oc debug command should not occasionally exit with error 

      Additional info:

          

            harpatil@redhat.com Harshal Patil
            harpatil@redhat.com Harshal Patil
            ying zhou ying zhou
            Votes:
            0 Vote for this issue
            Watchers:
            7 Start watching this issue

              Created:
              Updated:
              Resolved: