Uploaded image for project: 'OpenShift Bugs'
  1. OpenShift Bugs
  2. OCPBUGS-25459

Tests failing in CI since base image changes

    XMLWordPrintable

Details

    • No
    • False
    • Hide

      None

      Show
      None

    Description

      This is a clone of issue OCPBUGS-18338. The following is the description of the original issue:

      Description of problem:

      Tests like lint and vet used to be ran within a container engine by
      default if an engine was detected, both locally and in CI.Up until now no container engine was detected in CI, so tests would run natively there.Now that the base image we use in CI has now started
      shipping `podman`, a container engine is detected by default and tests
      are run within podman by default. But creating nested containers doesn't
      work in CI at the moment and thus results in a test failure.As such we are switching the default behaviour for tests (both locally
      and in CI), where now by
      default no container engine is used to run tests, even if one is
      detected, but instead tests are run natively unless otherwise specifi
      

      Version-Release number of selected component (if applicable):

       

      How reproducible:

      Always

      Steps to Reproduce:

      1.
      2.
      3.
      

      Actual results:

       

      Expected results:

       

      Additional info:

       

      Attachments

        Issue Links

          Activity

            People

              rmanak@redhat.com Radek Manak
              openshift-crt-jira-prow OpenShift Prow Bot
              Zhaohua Sun Zhaohua Sun
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: