Uploaded image for project: 'OpenShift Bugs'
  1. OpenShift Bugs
  2. OCPBUGS-18530

/etc/kubernets/manifests/kube-apiserver-pod.yaml missing in the node

    XMLWordPrintable

Details

    • Bug
    • Resolution: Duplicate
    • Critical
    • None
    • 4.13.0
    • None
    • No
    • Proposed
    • False
    • Hide

      None

      Show
      None
    • Hide
      we can this error message in the node esx03.rackf10.local

      Sep 04 08:02:29 c2-esx02.rackf10.local kubenswrapper[8793]: E0904 08:02:29.208979 8793 kubelet_node_status.go:94] "Unable to register node with API server" err="Post \"https://api-int.c2-raven.rackf10.local:6443/api/v1/nodes\": dial tcp 20.14.32.222:6443: connect: connection refused" node="c2-esx02.rackf10.local"

      esx03.rackf10.local is the problem. It serves the api-int VIP but it doesn't have kube-apiserver running

      Due to this all the requests to api-int will fail

      Need to figure out why kube-apiserver-pod.yaml is missing

      I am attaching journal logs and sos report of the kube-apiserver-pod.yaml missing node and mustgather report


      Show
      we can this error message in the node esx03.rackf10.local Sep 04 08:02:29 c2-esx02.rackf10.local kubenswrapper[8793]: E0904 08:02:29.208979 8793 kubelet_node_status.go:94] "Unable to register node with API server" err="Post \" https://api-int.c2-raven.rackf10.local:6443/api/v1/nodes \": dial tcp 20.14.32.222:6443: connect: connection refused" node="c2-esx02.rackf10.local" esx03.rackf10.local is the problem. It serves the api-int VIP but it doesn't have kube-apiserver running Due to this all the requests to api-int will fail Need to figure out why kube-apiserver-pod.yaml is missing I am attaching journal logs and sos report of the kube-apiserver-pod.yaml missing node and mustgather report

    Description

      Description of problem:

      Sep 04 08:02:29 c2-esx02.rackf10.local kubenswrapper[8793]: E0904 08:02:29.208979    8793 kubelet_node_status.go:94] "Unable to register node with API server" err="Post \"https://api-int.c2-raven.rackf10.local:6443/api/v1/nodes\": dial tcp 20.14.32.222:6443: connect: connection refused" node="c2-esx02.rackf10.local"
      
      
      To troubleshoot this error we have tried ssh into node (20.14.32.222) c2-esx03.rackf10.local node 
      
      Executed  below command:
      
      $ crictl ps -a |grep api
      
      There is no kupeapi server pod was running.
      
      I have  checked in node c2-esx03.rackf10.local noticed that etc/kubernets/manifests/kube-apiserver-pod.yaml was  missing
      
      Need to find out the reason why kube-apiserver-pod.yaml  was missing in the node.  
      

      Version-Release number of selected component (if applicable):

      4.13.10

      How reproducible:

      10% at customer's site

      Steps to Reproduce:

      1.
      2.
      3.
      

      Actual results:

       

      Expected results:

       

      Additional info:

       

      Attachments

        Issue Links

          Activity

            People

              bnemec@redhat.com Benjamin Nemec
              rhn-support-bhab Bharathi B
              Manoj Hans Manoj Hans
              Votes:
              0 Vote for this issue
              Watchers:
              10 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: