Uploaded image for project: 'OpenShift Bugs'
  1. OpenShift Bugs
  2. OCPBUGS-18398

[4.13] ETCD backup script fails on FIPS enabled cluster

    XMLWordPrintable

Details

    • Bug
    • Resolution: Done
    • Blocker
    • None
    • 4.13.z, 4.14.0
    • Etcd
    • Critical
    • No
    • Rejected
    • False
    • Hide

      None

      Show
      None

    Description

      This is a clone of issue OCPBUGS-18179. The following is the description of the original issue:

      Description of problem:

      etcd-backup fails with 'FIPS mode is enabled, but the required OpenSSL library is not available' on 4.13 FIPS enabled cluster

      Version-Release number of selected component (if applicable):

      OCP 4.13

      How reproducible:

       

      Steps to Reproduce:

      1. run etcd-backup script on FIPS enabled OCP 4.13
      2.
      3.
      

      Actual results:

      backup script fails with
      
      + etcdctl snapshot save /home/core/assets/backup/snapshot_2023-08-28_125218.db
      FIPS mode is enabled, but the required OpenSSL library is not available

      Expected results:

      successful run of etcd-backup script

      Additional info:

      4.13 uses RHEL9-based RHCOS while ETCD image still use RHEL8 and this could be main issue. If so, image should be rebuilt with RHEL9.

      Attachments

        Issue Links

          Activity

            People

              tjungblu@redhat.com Thomas Jungblut
              openshift-crt-jira-prow OpenShift Prow Bot
              ge liu ge liu
              Votes:
              1 Vote for this issue
              Watchers:
              10 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: