Uploaded image for project: 'OpenShift Bugs'
  1. OpenShift Bugs
  2. OCPBUGS-18339

Machine API Operator vSphere controller references retired KCS for HW Version Migrations

    XMLWordPrintable

Details

    • No
    • CLOUD Sprint 244
    • 1
    • Rejected
    • False
    • Hide

      None

      Show
      None
    • N/A
    • Release Note Not Required

    Description

      Description of problem:

      The vSphere code references a Red Hat solution that has been retired in favour of the code being merged into the official documentation.
      
      https://github.com/openshift/machine-api-operator/blob/master/pkg/controller/vsphere/reconciler.go#L827

      Version-Release number of selected component (if applicable):

      4.11-4.13 + main

      How reproducible:

      Always

      Steps to Reproduce:

      1.
      2.
      3.
      

      Actual results:

      UI presents a message with solution customers can not access.
      
      Hardware lower than 15 is not supported, clone stopped. Detected machine template version is 13. Please update machine template: https://access.redhat.com/articles/6090681

      Expected results:

      Should referenced official documentation: https://docs.openshift.com/container-platform/4.12/updating/updating-hardware-on-nodes-running-on-vsphere.html

      Additional info:

       

      Attachments

        Issue Links

          Activity

            People

              rh-ee-nbrubake Nolan Brubaker
              rhn-support-mrobson Matt Robson
              Huali Liu Huali Liu
              Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: