Uploaded image for project: 'OpenShift Bugs'
  1. OpenShift Bugs
  2. OCPBUGS-13963

Bump cluster-ingress-operator to k8s APIs v0.27

XMLWordPrintable

    • Icon: Bug Bug
    • Resolution: Done-Errata
    • Icon: Critical Critical
    • 4.14.0
    • 4.14
    • Networking / router
    • None
    • Important
    • 3
    • Sprint 236
    • 1
    • Rejected
    • False
    • Hide

      None

      Show
      None
    • N/A
    • Release Note Not Required
    • Done

      Description of problem:

      The current version of openshift/cluster-ingress-operator vendors Kubernetes 1.26 packages. OpenShift 4.13 is based on Kubernetes 1.27.   

      Version-Release number of selected component (if applicable):

      4.14

      How reproducible:

      Always

      Steps to Reproduce:

      1. Check https://github.com/openshift/cluster-ingress-operator/blob/release-4.14/go.mod 

      Actual results:

      Kubernetes packages (k8s.io/api, k8s.io/apimachinery, and k8s.io/client-go) are at version v0.26
      

      Expected results:

      Kubernetes packages are at version v0.27.0 or later.

      Additional info:

      Using old Kubernetes API and client packages brings risk of API compatibility issues.
      controller-runtime will need to be bumped to 1.15 as well

            gspence@redhat.com Grant Spence
            gspence@redhat.com Grant Spence
            Shudi Li Shudi Li
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

              Created:
              Updated:
              Resolved: