Uploaded image for project: 'OpenShift Bugs'
  1. OpenShift Bugs
  2. OCPBUGS-13188

cloud-controller-manager should be Upgradeable=True on 4.12 None clusters

    XMLWordPrintable

Details

    • Moderate
    • Yes
    • CLOUD Sprint 235, CLOUD Sprint 236
    • 2
    • False
    • Hide

      None

      Show
      None

    Description

      Description of problem:

      Possibly a regression introduced by OCPBUGS-7898, but a 4.12.14 cluster with None infrastructure submitted the following Insights for the cloud-controller-manager ClusterOperator:

      2023-05-05T00:08:07Z Upgradeable=False AsExpected:
      

      Version-Release number of selected component (if applicable):

      4.12.14

      How reproducible:

      Unclear.

      Steps to Reproduce:

      1. Run a 4.12.14 cluster, for some unclear subset of cluster configuration.
      2. $ oc get -o json clusteroperator cloud-controller-manager | jq '.status.conditions[] | select(.type == "Upgradeable")'

      Actual results:

      False with AsExpected and an empty message.

      Expected results:

      True with AsExpected, or False with a different reason and a message.

      Attachments

        Issue Links

          Activity

            People

              mimccune@redhat.com Michael McCune
              trking W. Trevor King
              Milind Yadav Milind Yadav
              Votes:
              0 Vote for this issue
              Watchers:
              8 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: