Uploaded image for project: 'OpenShift Bugs'
  1. OpenShift Bugs
  2. OCPBUGS-1251

Add admin acknowledgement in 4.11 for API removals in 4.12

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Critical
    • Resolution: Done
    • 4.11.z
    • None
    • None
    • Important
    • OTA 224
    • 1
    • Hide

      None

      Show
      None

    Description

      Description of problem:

      We need to have admin-ack in 4.11 so that admins can check the deprecated APIs and approve when they move to 4.12.Refer https://access.redhat.com/articles/6955381 for  more information. As planned we want to add the admin-ack around 4.12 feature freeze. 

      Version-Release number of selected component (if applicable):

      4.11

      How reproducible:

      Always

      Steps to Reproduce:

      1. Install a cluster in 4.11. 
      2. Run an application which uses the deprecated API. See https://access.redhat.com/articles/6955381 for more information.
      3. Upgrade to 4.12

      Actual results:

      The upgrade happens without asking the admin to confirm that the worksloads do not use the deprecated APIs.

      Expected results:

      Upgrade should wait for the admin-ack.

      Additional info:

      We had admin-acks in the past too e.g. https://docs.openshift.com/container-platform/4.9/updating/updating-cluster-prepare.html#update-preparing-migrate_updating-cluster-prepare

      Attachments

        Issue Links

          Activity

            People

              lmohanty@redhat.com Lalatendu Mohanty
              lmohanty@redhat.com Lalatendu Mohanty
              Evgeni Vakhonin Evgeni Vakhonin
              Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: