Uploaded image for project: 'ModeShape'
  1. ModeShape
  2. MODE-2133

BOM changes in 3.7 may break application builds

    Details

      Description

      ModeShape 3.7.0.Final included several changes to the BOMs (see MODE-2092) that eliminated some non org.modeshape third-party library version specifications in the <dependencyManagement> section, which defines default dependency information. For example, per our Getting Started documentation, an application was not required to specify the version of the logging framework, even though doing so is a recommended practice. Therefore, although the changes made in MODE-2092 were more correct from a BOM perspective, the changes also were not backward compatible with the state of the BOMs in 3.6 or earlier, and thus might cause unexpected problems for applications that are upgraded from 3.6 to 3.7.

      Therefore, we need to patch 3.7.0.Final and fix the BOMs so that applications can use them just as easily as with 3.6.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  hchiorean Horia Chiorean
                  Reporter:
                  rhauch Randall Hauch
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: