Uploaded image for project: 'ModeShape'
  1. ModeShape
  2. MODE-1733

Problems with defining node types in clustered environment with eviction enabled

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Done
    • Affects Version/s: 3.0.1.Final
    • Fix Version/s: 3.1.0.Final
    • Component/s: Clustering
    • Labels:
      None
    • Steps to Reproduce:
      Hide

      Start up two clustered instances of Modeshape with .CND defined node types. When the two instances communicate, an NPE is thrown on the first instance and the second instance gets a failed transaction since the sync failed between the two instances.

      Show
      Start up two clustered instances of Modeshape with .CND defined node types. When the two instances communicate, an NPE is thrown on the first instance and the second instance gets a failed transaction since the sync failed between the two instances.
    • Workaround:
      Workaround Exists
    • Workaround Description:
      Hide

      One workaround appears to be to not use eviction. This is not ideal, since that means that the Infinispan cache attempts to keep all nodes in-memory. However, it may be a practical workaround for smaller repositories.

      Show
      One workaround appears to be to not use eviction. This is not ideal, since that means that the Infinispan cache attempts to keep all nodes in-memory. However, it may be a practical workaround for smaller repositories.

      Description

      We are having a problem running ModeShape in a clustered environment. The issue arises when we attempt to define custom node types (via a .cnd file) in our .json repository configuration file. The first instance of Modeshape comes up fine. The problem is when the second instance comes up. We get a stack trace containing an NPE on both instances. This happens every time at startup. When we remove the reference to the .cnd file from the repository .json file, everything starts up properly.

      This may to be related to MODE-1703, which appears to have been fixed back about 24 days ago, but we are still seeing a problem. Any help on this would be greatly appreciated. We are evaluating ModeShape as our repository of choice, and this is currently a blocker for us.

        Attachments

        1. build.output.zip
          71 kB
        2. firstInstance.log
          22 kB
        3. modeshape.zip
          17 kB
        4. repository1.json
          0.9 kB
        5. repository2.json
          0.9 kB
        6. repository-infinispan-test1.xml
          4 kB
        7. repository-infinispan-test2.xml
          4 kB
        8. repository-test.cnd
          0.2 kB
        9. secondInstance.log
          56 kB

          Issue Links

            Activity

              People

              Assignee:
              rhauch Randall Hauch
              Reporter:
              rickcole3 Rick Cole (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: