Uploaded image for project: 'ModeShape'
  1. ModeShape
  2. MODE-1108

Add compilation support in for JDK 1.5 for downstream projects

    Details

      Description

      In Guvnor we compile against ModeShape in the guvnor-repository-connector-modeshape module. It will a very thin layer so we get isolate ourselves from the differences between JCR implementations. Guvnor will still need to support 1.5, for at least another year. However the majority of our users are on 1.6. it would be preferable if switching from JackRabbit to ModeShape would only be a config change however, our guvnor-repository-connector-modeshape module requires 1.6 to compile against ModeShape. If ModeShape add 1.5 backward compatibility to the following modules: modeshape-graph, modeshape-jcr, and modeshape-jcr-api, then we can compile with 1.5, and this would allow us to add the guvnor-repository-connector-modeshape as part of the guvnor.war. Yes people running 1.5 can still not run ModeShape, but all for all our 1.6 users things would just work (we did this for BRMS too). At that time these 3 modules did not use any 1.6 features, so I hope that this small change can make it into the 2.5 release.

      Thanks!

      --Kurt

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  kurtstam Kurt Stam
                  Reporter:
                  kurtstam Kurt Stam
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: