Uploaded image for project: 'mod_cluster'
  1. mod_cluster
  2. MODCLUSTER-308

Backport MODCLUSTER-307: Issues using mod_cluster with Tomcat 6 and Executor thread pools

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Minor
    • Resolution: Out of Date
    • MOD_CLUSTER_1_0_10_GA_CP02
    • None
    • None
    • None
    • Workaround Exists
    • Hide

      -Don't use an Executor thread pool

      OR

      -Use a load metric other than the BusyConnectorsLoadMetric when using an Executor thread pool.

      Show
      -Don't use an Executor thread pool OR -Use a load metric other than the BusyConnectorsLoadMetric when using an Executor thread pool.
    • If it is pertinent to newer Tomcats, please reopen. Tomcat 6 is nearing its End of Life.

    Description

      mod_cluster cannot properly determine connector pool statistics from Tomcat 6 when using an Executor thread pool. The Tomcat server successfully connects with Apache/mod_cluster, but the worker never fully initializes as it only reports a load factor of -1 since it cannot properly determine stats from the Executor pool.

      Attachments

        Issue Links

          Activity

            People

              rhn-engineering-jclere Jean-Frederic Clere
              rhn-support-aogburn Aaron Ogburn
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: