Uploaded image for project: 'OpenShift Logging'
  1. OpenShift Logging
  2. LOG-3584

CLO Version 5.6 Gives Incompatible warning on OCP version 4.12 for OCP version higher than 4.12


    • False
    • None
    • False
    • NEW
    • NEW
    • Before this update the Operator incorrectly generated incompatibility warnings on {product-title} 4.12+. With this update, the Operator max {product-title} version value has been corrected, resolving the issue.
    • Bug Fix
    • Done
    • Log Collection - Sprint 231, Log Collection - Sprint 232

      Description of problem:


      OCP 4.12 cluster gives incompatible warnings while Using CLO ES and Loki Version 5.6 which should not be happening

      Version-Release number of selected component (if applicable):

      OCP version 4.12 and CLO ES and Loki version 5.6

      How reproducible:

      Steps to Reproduce:

      1.  On an OCP cluster running version 4.12
      2. Install Loki/ES and CLO with version 5.6
      3. ...

      Actual results:

      Cluster gives Warning 
      olm.maxOpenShiftVersion=4.12 in csv operatorframework.io/properties

      Expected results:

      olm.maxOpenShiftVersion=4.13 in csv operatorframework.io/properties

      No Warning

      Additional info:

            jcantril@redhat.com Jeffrey Cantrill
            rhn-support-ssonigra Sonigra Saurab
            1 Vote for this issue
            4 Start watching this issue