Uploaded image for project: 'Kogito'
  1. Kogito
  2. KOGITO-7230

Upgrade dependencies with reported vulnerabilities

    XMLWordPrintable

Details

    • ---
    • ---

    Description

      Summary
      We use <version.com.google.code.gson>2.8.6</version.com.google.code.gson>
      which has high severity sec vulnerability.
      Same goes for <version.com.fasterxml.jackson>2.12.6</version.com.fasterxml.jackson>
      and <version.org.wildfly.core>11.1.1.Final</version.org.wildfly.core>

      Updating
      <version.org.hibernate.validator>4.1.0.Final</version.org.hibernate.validator> is out of scope as it requires additional work to fix builds.

      Acceptance criteria
      Use <version.com.google.code.gson>2.9.0</version.com.google.code.gson>
      Use <version.com.fasterxml.jackson>2.13.3</version.com.fasterxml.jackson>
      use <version.org.wildfly.core>18.1.1.Final</version.org.wildfly.core>

      Attachments

        Activity

          People

            dhanak@redhat.com Dominik Hanak
            dhanak@redhat.com Dominik Hanak
            Tomas David Tomas David
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: