Uploaded image for project: 'jBPM'
  1. jBPM
  2. JBPM-10101

kafka-clients misalignment with any supported AMQ Streams version

XMLWordPrintable

    • Icon: Bug Bug
    • Resolution: Done
    • Icon: Critical Critical
    • 7.74.0.Final
    • None
    • None
    • None

      Kafka dependencies for community are not aligned with the ones supported by RHOAR for RHPAM 7.13

      Right now current version of Kafka community version is 2.8.0 and it should be aligned with the version used by AMQ Streams 2.1.0 which is 3.1.0 for the community.

      There are 3 different places where we are using this dependency (kafka-clients):

      1. jbpm-work-items. This is a provided dependency, so not a major issue here since this dep will be provided by users [1]. For instance, through SB embedded engines.
      2. kie-server. Here the only possible workaround would be to replace the dep in the WEB-INF/lib folder for this binary, or just keep using the same kafka client version and connect to a AMQ Stream 2.1 instance.
      3. jbpm-event-emitters. Same as 1 [3] 

      [1] https://github.com/kiegroup/jbpm-work-items/blob/7.67.x/kafka-workitem/pom.xml#L13-L17

      [2] https://github.com/kiegroup/droolsjbpm-integration/blob/7.67.x/kie-server-parent/kie-server-services/kie-server-services-kafka/pom.xml#L64-L67

      [3] https://github.com/kiegroup/jbpm/blob/7.67.x/jbpm-event-emitters/jbpm-event-emitters-kafka/pom.xml#L29-L33

            rhn-support-egonzale Enrique Gonzalez Martinez (Inactive)
            rhn-support-egonzale Enrique Gonzalez Martinez (Inactive)
            Antonio Fernandez Alhambra Antonio Fernandez Alhambra (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Created:
              Updated:
              Resolved: