Uploaded image for project: 'Tools (JBoss Tools)'
  1. Tools (JBoss Tools)
  2. JBIDE-9339

VPE should have better exceptions handling related to third party templates

    XMLWordPrintable

Details

    Description

      Guys I can not imagine how you handle/find such real life issues in VPE like I get last time. Now I know this is my issue in my plugable VPE template (it was NPE exception) - but how I find this?! This is a really epic story. No exceptions in Error Log - just Eclipse "graceful" crash with this log in console:

      >>>
      Configuration location:
      file:/C:/_ws/xx_vpe/.metadata/.plugins/org.eclipse.pde.core/New_configuration/
      Configuration file:
      file:/C:/_ws/xx_vpe/.metadata/.plugins/org.eclipse.pde.core/New_configuration/config.ini loaded
      Install location:
      file:/C:/Bin/eclipse_3.7/
      Framework located:
      file:/C:/Bin/eclipse_3.7/plugins/org.eclipse.osgi_3.7.0.v20110613.jar
      Loading extension: reference:file:javax.transaction_1.1.1.v201105210645.jar
      eclipse.properties not found
      Framework classpath:
      file:/C:/Bin/eclipse_3.7/plugins/org.eclipse.osgi_3.7.0.v20110613.jar
      file:/C:/Bin/eclipse_3.7/plugins/
      file:/C:/Bin/eclipse_3.7/plugins/javax.transaction_1.1.1.v201105210645.jar
      Splash location:
      C:\Bin\eclipse_3.7\plugins\org.eclipse.platform_3.7.0.v201106131736\splash.bmp
      Debug options:
      file:/C:/_ws/xx_vpe/.metadata/.plugins/org.eclipse.pde.core/New_configuration/.options loaded
      Time to load bundles: 94
      Starting application: 6839
      !SESSION 2011-07-13 19:56:53.561 -----------------------------------------------
      eclipse.buildId=I20110613-1736
      java.version=1.6.0_24
      java.vendor=Sun Microsystems Inc.
      BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
      Framework arguments: -product org.eclipse.sdk.ide
      Command-line arguments: -product org.eclipse.sdk.ide -data C:_ws\xx_vpe/../runtime-New_configuration -dev file:C:/_ws/xx_vpe/.metadata/.plugins/org.eclipse.pde.core/New_configuration/dev.properties -debug C:_ws\xx_vpe\.metadata\.plugins\org.eclipse.pde.core\New_configuration/.options -os win32 -ws win32 -arch x86 -consoleLog

      !ENTRY org.eclipse.mylyn.tasks.ui 2 0 2011-07-13 19:57:06.090
      !MESSAGE No search provider was registed. Tasks search is not available.
      Application Started: 29190
      #

      1. A fatal error has been detected by the Java Runtime Environment:
        #
      2. EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x642c902e, pid=9748, tid=9460
        #
      3. JRE version: 6.0_24-b07
      4. Java VM: Java HotSpot(TM) Client VM (19.1-b02 mixed mode, sharing windows-x86 )
      5. Problematic frame:
      6. C [js3250.dll+0x4902e]
        #
      7. An error report file with more information is saved as:
      8. C:\Bin\eclipse_3.7\hs_err_pid9748.log
        #
      9. If you would like to submit a bug report, please visit:
      10. http://java.sun.com/webapps/bugreport/crash.jsp
      11. The crash happened outside the Java Virtual Machine in native code.
      12. See problematic frame for where to report the bug.
        #
        >>>

      Attachments

        1. hs_err_pid9748.log
          20 kB
        2. JBIDE-9339_20110713.patch
          4 kB
        3. screenshot-1.jpg
          screenshot-1.jpg
          28 kB

        Issue Links

          Activity

            People

              nivologd@gmail.com Denis Golovin
              vyemialyanchyk_jira Vitali Yemialyanchyk (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: