Uploaded image for project: 'Tools (JBoss Tools)'
  1. Tools (JBoss Tools)
  2. JBIDE-8446

<rich:validator /> validation message don´t work in Eclipse/JBoss Tools browser

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: 3.2.0.CR1
    • Fix Version/s: 3.2.0.Final
    • Component/s: upstream
    • Labels:
      None

      Description

      <rich:validator /> validation message don´t work in Eclipse/JBoss Tools browser. Works fine in IE, FireFox and Google Chrome.

      Exeample:

      <?xml version="1.0" encoding="UTF-8" ?>
      <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
      <html xmlns="http://www.w3.org/1999/xhtml"
      xmlns:h="http://java.sun.com/jsf/html"
      xmlns:f="http://java.sun.com/jsf/core"
      xmlns:a4j="http://richfaces.org/a4j"
      xmlns:rich="http://richfaces.org/rich">
      <h:head>
      <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
      <title>My Richfaces 4.0 rich:validation test</title>
      </h:head>
      <h:body>
      <h:form>
      <rich:panel>
      <h:inputText id="idInput1">
      <f:validateLength maximum="5"/>
      <rich:validator />
      </h:inputText>
      <rich:message for="idInput1"/>
      <a4j:commandButton value="Submit"/>
      </rich:panel>
      </h:form>
      </h:body>
      </html>

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                flaviohenrique Flávio Henrique
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: