Uploaded image for project: 'Tools (JBoss Tools)'
  1. Tools (JBoss Tools)
  2. JBIDE-8193

Mavenized new Seam web project cannot be built

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate Issue
    • Affects Version/s: 3.2.0.CR1
    • Fix Version/s: 3.2.0.CR1
    • Component/s: maven
    • Labels:
      None
    • Steps to Reproduce:
      Hide

      1. cleanup (or move) your .m2 repository
      2. create new seam EAR web project with our maven integration facet
      Result: after a while of downloading, this is the end of whole process

      1/21/11 2:34:45 PM CET: [WARN] The POM for org.jboss.seam.embedded:hibernate-all:jar:beta3.SP13 is missing, no dependency information available
      1/21/11 2:34:45 PM CET: [WARN] The POM for org.jboss.seam.embedded:jboss-embedded-all:jar:beta3.SP13 is missing, no dependency information available
      1/21/11 2:34:45 PM CET: [WARN] The POM for org.jboss.seam.embedded:thirdparty-all:jar:beta3.SP13 is missing, no dependency information available
      1/21/11 2:34:45 PM CET: [WARN] The POM for org.richfaces.framework:richfaces-api:jar:3.3.1.SP2 is missing, no dependency information available
      1/21/11 2:34:46 PM CET: Build errors for proj2-test; org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal on project proj2-test: Could not resolve dependencies for project org.jboss.tools:proj2-test:jar:0.0.1-SNAPSHOT: Failure to find org.richfaces.framework:richfaces-api:jar:3.3.1.SP2 in https://repository.jboss.org/nexus/content/groups/public/ was cached in the local repository, resolution will not be reattempted until the update interval of jboss-public-repository-group has elapsed or updates are forced

      I am not a big fun of maven and do not really understand, where the problem could be. But something tells me, that this should work.
      Could you provide a workaround or an advice?

      Show
      1. cleanup (or move) your .m2 repository 2. create new seam EAR web project with our maven integration facet Result: after a while of downloading, this is the end of whole process 1/21/11 2:34:45 PM CET: [WARN] The POM for org.jboss.seam.embedded:hibernate-all:jar:beta3.SP13 is missing, no dependency information available 1/21/11 2:34:45 PM CET: [WARN] The POM for org.jboss.seam.embedded:jboss-embedded-all:jar:beta3.SP13 is missing, no dependency information available 1/21/11 2:34:45 PM CET: [WARN] The POM for org.jboss.seam.embedded:thirdparty-all:jar:beta3.SP13 is missing, no dependency information available 1/21/11 2:34:45 PM CET: [WARN] The POM for org.richfaces.framework:richfaces-api:jar:3.3.1.SP2 is missing, no dependency information available 1/21/11 2:34:46 PM CET: Build errors for proj2-test; org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal on project proj2-test: Could not resolve dependencies for project org.jboss.tools:proj2-test:jar:0.0.1-SNAPSHOT: Failure to find org.richfaces.framework:richfaces-api:jar:3.3.1.SP2 in https://repository.jboss.org/nexus/content/groups/public/ was cached in the local repository, resolution will not be reattempted until the update interval of jboss-public-repository-group has elapsed or updates are forced I am not a big fun of maven and do not really understand, where the problem could be. But something tells me, that this should work. Could you provide a workaround or an advice?

      Gliffy Diagrams

        Attachments

          Activity

            People

            • Assignee:
              snjeza Snjezana Peco
              Reporter:
              lzoubek Libor Zoubek
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: