Uploaded image for project: 'Tools (JBoss Tools)'
  1. Tools (JBoss Tools)
  2. JBIDE-27860

OpenShift Application explorer: Cannot debug S2I Component

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Won't Do
    • 4.19.1.AM1
    • None
    • openshift
    • None
    • Hide

      1. Create launcher project: rest-http and vertx community
      2. Create project in OpenShift Application explorer
      3. Create component in OpenShift project: select launcher project as eclipse project, select S2I java image and app names
      4. wait for component creation and app running
      5. Set breakpoints and try to debug
      Result: Error: debugging is not supported for this type of component

      Expected: No error message and debugging is working

      Show
      1. Create launcher project: rest-http and vertx community 2. Create project in OpenShift Application explorer 3. Create component in OpenShift project: select launcher project as eclipse project, select S2I java image and app names 4. wait for component creation and app running 5. Set breakpoints and try to debug Result: Error: debugging is not supported for this type of component Expected: No error message and debugging is working

    Description

      Debugging does not work for S2I images: I have tried vertx/java application and node.

      Attachments

        Activity

          People

            Unassigned Unassigned
            jkopriva@redhat.com Josef Kopriva
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: