Uploaded image for project: 'Tools (JBoss Tools)'
  1. Tools (JBoss Tools)
  2. JBIDE-27605

Conflicting dependency when updating from BYOE 2020-09 + JBT 4.17.0.Final to JBT 4.18.0.Final

    XMLWordPrintable

Details

    • Bug
    • Status: Reopened (View Workflow)
    • Critical
    • Resolution: Unresolved
    • 4.18.0.Final
    • 4.21.x
    • updatesite
    • None
    • Sprint #199 Apr 2021
    • 1
    • Workaround Exists
    • Hide
      1. Help -> Install New Software
      2. Add studio update site
      3. Choose what (all) do you want to install
      4. Perform installation from update

      OR

      1. Preferences -> Install/Update -> Available Software and disable Latest eclipse release
      2. This will together with JBT also installs eclpse 2020-12 (unsupported/untested)
      Show
      Help -> Install New Software Add studio update site Choose what (all) do you want to install Perform installation from update OR Preferences -> Install/Update -> Available Software and disable Latest eclipse release This will together with JBT also installs eclpse 2020-12 (unsupported/untested)
    • ---
    • ---

    Description

      When on BYOE 2020-09 + JBT 4.17 from stable update site, I am trying to install JBT 4.18.0.Final from snapshots update site using an option: `check for updates` and I get conflicting dependencies. Installation/upgrade can proceed though. 

      Note: This time I have checked out 'Latest Eclipse Release' update site to stick with Eclipse 2020-09. Preferences -> Install/Update -> Available software. 

      Attachments

        Issue Links

          Activity

            People

              stephane.bouchet Stephane Bouchet
              odockal@redhat.com Ondrej Dockal
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated: