Uploaded image for project: 'Tools (JBoss Tools)'
  1. Tools (JBoss Tools)
  2. JBIDE-27323

Installing all SW from central throws multiple dependency errors in Studio/Tools with openjdk 1.8

    Details

    • Sprint:
      devex #186 July 2020

      Description

      Installing all SW from central with enabled early access in BYOE scenario (including eclipse-jee 2020-06 R and JBoss Tools installed from staging update site for 4.16.0.AM1) ended up with many errors.

       

      ie.:

      
      eclipse.buildId=12.16.0.AM1-v20200619-0713-B6514eclipse.buildId=12.16.0.AM1-v20200619-0713-B6514java.version=1.8.0_252java.vendor=Oracle CorporationBootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_USFramework arguments:  -product com.jboss.devstudio.core.productCommand-line arguments:  -data file:/home/odockal/workspace_12160AM1-B6514/ -os linux -ws gtk -arch x86_64 -product com.jboss.devstudio.core.product
      org.springframework.ide.eclipse.wizardErrorMon Jun 22 11:57:00 CEST 2020FrameworkEvent ERROR
      org.osgi.framework.BundleException: Could not resolve module: org.springframework.ide.eclipse.wizard [1477]  Unresolved requirement: Require-Bundle: org.springsource.ide.eclipse.commons.gettingstarted; bundle-version="3.5.0"; resolution:="optional"  Unresolved requirement: Require-Bundle: org.springsource.ide.eclipse.commons.browser; bundle-version="[3.5.0,4.0.0)"; resolution:="optional"  Unresolved requirement: Require-Bundle: org.springframework.ide.eclipse.quickfix    -> Bundle-SymbolicName: org.springframework.ide.eclipse.quickfix; bundle-version="3.9.12.202003180620-RELEASE"; singleton:="true"       org.springframework.ide.eclipse.quickfix [1469]         No resolution report for the bundle.  Bundle was not resolved because of a uses constraint violation.  org.apache.felix.resolver.reason.ReasonException: Uses constraint violation. Unable to resolve resource org.springframework.ide.eclipse.quickfix [osgi.identity; osgi.identity="org.springframework.ide.eclipse.quickfix"; type="osgi.bundle"; version:Version="3.9.12.202003180620-RELEASE"; singleton:="true"] because it is exposed to package 'javax.annotation' from resources org.eclipse.osgi [osgi.identity; type="osgi.bundle"; version:Version="3.15.300.v20200520-1959"; osgi.identity="org.eclipse.osgi"; singleton:="true"] and javax.annotation [osgi.identity; type="osgi.bundle"; version:Version="1.3.5.v20200504-1837"; osgi.identity="javax.annotation"] via two dependency chains.
      Chain 1:  org.springframework.ide.eclipse.quickfix [osgi.identity; osgi.identity="org.springframework.ide.eclipse.quickfix"; type="osgi.bundle"; version:Version="3.9.12.202003180620-RELEASE"; singleton:="true"]    require: (osgi.wiring.bundle=org.eclipse.core.runtime)     |    provide: osgi.wiring.bundle: org.eclipse.core.runtime  org.eclipse.osgi [osgi.identity; type="osgi.bundle"; version:Version="3.15.300.v20200520-1959"; osgi.identity="org.eclipse.osgi"; singleton:="true"]
      Chain 2:  org.springframework.ide.eclipse.quickfix [osgi.identity; osgi.identity="org.springframework.ide.eclipse.quickfix"; type="osgi.bundle"; version:Version="3.9.12.202003180620-RELEASE"; singleton:="true"]    require: (osgi.wiring.bundle=org.springframework.context)     |    provide: osgi.wiring.bundle; bundle-version:Version="4.3.23.20190313-CI"; osgi.wiring.bundle="org.springframework.context"  org.springframework.context [osgi.identity; osgi.identity="org.springframework.context"; type="osgi.bundle"; version:Version="4.3.23.20190313-CI"]    import: (&(osgi.wiring.package=javax.annotation)(version>=0.0.0))     |    export: osgi.wiring.package: javax.annotation  javax.annotation [osgi.identity; type="osgi.bundle"; version:Version="1.3.5.v20200504-1837"; osgi.identity="javax.annotation"] at org.eclipse.osgi.container.Module.start(Module.java:463) at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel$2.run(ModuleContainer.java:1845) at org.eclipse.osgi.internal.framework.EquinoxContainerAdaptor$1$1.execute(EquinoxContainerAdaptor.java:136) at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1838) at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1779) at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1743) at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1665) at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1) at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:234) at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:345)
      
      

       

      Please see attached log.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  stephane.bouchet Stephane Bouchet
                  Reporter:
                  odockal Ondrej Dockal
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: