Uploaded image for project: 'Tools (JBoss Tools)'
  1. Tools (JBoss Tools)
  2. JBIDE-26559

Unable to deploy a Java EE 8 project on EAP 7.2

    XMLWordPrintable

    Details

    • Type: Feature Request
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Done
    • Affects Version/s: 4.10.0.AM1
    • Fix Version/s: 4.11.0.AM1
    • Component/s: server
    • Labels:
      None
    • Sprint:
      devex #162 February 2019

      Description

      Unable to deploy a Java EE 8 (servlet 4.0) project on EAP 7.2, it does not support version 4.0 of the J2EE Web module specification.

      The project implements a simple servlet war that imports the org.jboss.bom:jboss-eap-javaee8:7.2.0.GA:pom.

      I am using adapter 3.6.2.v20190208-1835 which I think is the latest.

      According to JBIDE-26307 the 7.1 server adapter should be be used for EAP 7.2.

        Attachments

          Activity

            People

            Assignee:
            jeffmaury Jeff MAURY
            Reporter:
            andermaj Mattias Andersson (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: