Details

    • devex #156 October 2018, devex #157 November 2019

    Description

      Moving TP from 4.9 to 4.10 caused missing org.eclipse.epp.logging.aeri.ide plugin.

      One case how to reproduce this issue is to install RedDeer 2.4.0.M2 (Maybe even older 2.3.0.Final release) which requires aeri.core and aeri.ide plugins to be available. Restarting of devstudio after instalaltion or RD will shows in error log this:

      Error
      Tue Nov 20 10:11:03 CET 2018
      FrameworkEvent ERROR
      
      org.osgi.framework.BundleException: Could not resolve module: org.eclipse.reddeer.eclipse.test [1196]
      Unresolved requirement: Require-Bundle: org.eclipse.epp.logging.aeri.ide
      -> Bundle-SymbolicName: org.eclipse.epp.logging.aeri.ide; bundle-version="2.0.7.v20180504-0806"; singleton:="true"
      org.eclipse.epp.logging.aeri.ide [345]
      Unresolved requirement: Import-Package: org.apache.lucene.document; version="[7.1.0,8.0.0)"
      

      This is suggesting that it has something in common with lucene.core plugin. this might help identifying the root cause.

      Attachments

        Issue Links

          Activity

            People

              jmaury@redhat.com Jeff MAURY
              odockal@redhat.com Ondrej Dockal
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: