Uploaded image for project: 'Tools (JBoss Tools)'
  1. Tools (JBoss Tools)
  2. JBIDE-26158

[UPSTREAM] Server adapter: NPE when starting adapter for nodejs-mongo-persistent into Debug

    Details

      Description

      steps:

      1. EXEC: launch new application wizard, choose nodejs-mongo-persistent template and finish
      2. EXEC: when asked import the app and create a server adapter
      3. ASSERT: server adapter is created
      4. EXEC: start the server adapter
      5. ASSERT: server adapter is launched
      6. EXEC: restart the server adapter into Debug

      Result:
      Debuggin works, but you get the following error dialog:

      In the Eclipse log you'll find the following:

      java.lang.NullPointerException
      	at org.eclipse.core.internal.resources.CheckMissingNaturesListener.updateRange(CheckMissingNaturesListener.java:209)
      	at org.eclipse.core.internal.resources.CheckMissingNaturesListener$3.runInWorkspace(CheckMissingNaturesListener.java:179)
      	at org.eclipse.core.internal.resources.InternalWorkspaceJob.run(InternalWorkspaceJob.java:39)
      	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:60)
      

      ps. project context menu: Convert > Javascript Project doesn't help.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  adietish André Dietisheim
                  Reporter:
                  adietish André Dietisheim
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  4 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: