Uploaded image for project: 'Tools (JBoss Tools)'
  1. Tools (JBoss Tools)
  2. JBIDE-26027

Jetty FrameworkEvent ERROR for LiveReload

    Details

      Description

      When you install LiveReload from Central in devstudio 12.0.0.AM2, there are two errors due to incompatible version of Jetty:

      FrameworkEvent ERROR
      
      org.osgi.framework.BundleException: Could not resolve module: org.jboss.tools.livereload.core [1082]
        Unresolved requirement: Require-Bundle: org.eclipse.jetty.websocket.servlet; bundle-version="[9.4.0,9.5.0)"
          -> Bundle-SymbolicName: org.eclipse.jetty.websocket.servlet; bundle-version="9.4.8.v20171121"
             org.eclipse.jetty.websocket.servlet [1081]
               Unresolved requirement: Require-Capability: osgi.serviceloader; filter:="(osgi.serviceloader=org.eclipse.jetty.websocket.servlet.WebSocketServletFactory)"; cardinality:="multiple"
                 -> Provide-Capability: osgi.serviceloader; osgi.serviceloader="org.eclipse.jetty.websocket.servlet.WebSocketServletFactory"
                    org.eclipse.jetty.websocket.server [1080]
                      Unresolved requirement: Import-Package: org.eclipse.jetty.websocket.servlet; version="[9.4.8,9.4.9)"
                        -> Export-Package: org.eclipse.jetty.websocket.servlet; bundle-symbolic-name="org.eclipse.jetty.websocket.servlet"; bundle-version="9.4.8.v20171121"; version="9.4.8"
                      Unresolved requirement: Require-Capability: osgi.extender; filter:="(osgi.extender=osgi.serviceloader.registrar)"
                        -> Provide-Capability: osgi.extender; osgi.extender="osgi.serviceloader.registrar"; version:Version="1.0.0"
                           org.apache.aries.spifly.dynamic.bundle [1073]
                             No resolution report for the bundle.         Unresolved requirement: Require-Capability: osgi.extender; filter:="(osgi.extender=osgi.serviceloader.processor)"
                 -> Provide-Capability: osgi.extender; osgi.extender="osgi.serviceloader.processor"; version:Version="1.0.0"
        Unresolved requirement: Require-Bundle: org.eclipse.jetty.websocket.server; bundle-version="[9.4.0,9.5.0)"
          -> Bundle-SymbolicName: org.eclipse.jetty.websocket.server; bundle-version="9.4.8.v20171121"
        Unresolved requirement: Require-Bundle: org.apache.aries.spifly.dynamic.bundle; bundle-version="1.0.2"
          -> Bundle-SymbolicName: org.apache.aries.spifly.dynamic.bundle; bundle-version="1.0.2"
        Bundle was not resolved because of a uses contraint violation.
        org.osgi.service.resolver.ResolutionException: Uses constraint violation. Unable to resolve resource org.apache.aries.spifly.dynamic.bundle [osgi.identity; osgi.identity="org.apache.aries.spifly.dynamic.bundle"; type="osgi.bundle"; version:Version="1.0.2"] because it is exposed to package 'org.objectweb.asm' from resources org.objectweb.asm [osgi.identity; type="osgi.bundle"; version:Version="5.0.1.v201404251740"; osgi.identity="org.objectweb.asm"] and org.objectweb.asm [osgi.identity; type="osgi.bundle"; version:Version="6.0.0.v20170929-1901"; osgi.identity="org.objectweb.asm"] via two dependency chains.
      
      Chain 1:
        org.apache.aries.spifly.dynamic.bundle [osgi.identity; osgi.identity="org.apache.aries.spifly.dynamic.bundle"; type="osgi.bundle"; version:Version="1.0.2"]
          import: (&(osgi.wiring.package=org.objectweb.asm)(&(version>=5.0.0)(!(version>=6.0.0))))
           |
          export: osgi.wiring.package: org.objectweb.asm
        org.objectweb.asm [osgi.identity; type="osgi.bundle"; version:Version="5.0.1.v201404251740"; osgi.identity="org.objectweb.asm"]
      
      Chain 2:
        org.apache.aries.spifly.dynamic.bundle [osgi.identity; osgi.identity="org.apache.aries.spifly.dynamic.bundle"; type="osgi.bundle"; version:Version="1.0.2"]
          import: (&(osgi.wiring.package=org.objectweb.asm.commons)(&(version>=5.0.0)(!(version>=6.0.0))))
           |
          export: osgi.wiring.package=org.objectweb.asm.commons; uses:=org.objectweb.asm
        org.objectweb.asm.commons [osgi.identity; osgi.identity="org.objectweb.asm.commons"; type="osgi.bundle"; version:Version="5.0.1.v201404251740"]
          import: (osgi.wiring.package=org.objectweb.asm)
           |
          export: osgi.wiring.package: org.objectweb.asm
        org.objectweb.asm [osgi.identity; type="osgi.bundle"; version:Version="6.0.0.v20170929-1901"; osgi.identity="org.objectweb.asm"]
      	at org.eclipse.osgi.container.Module.start(Module.java:444)
      	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1682)
      	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1661)
      	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1624)
      	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1555)
      	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
      	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
      	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
      
      FrameworkEvent ERROR
      
      org.osgi.framework.BundleException: Could not resolve module: org.jboss.tools.livereload.ui [1083]
        Unresolved requirement: Require-Bundle: org.jboss.tools.livereload.core; bundle-version="1.0.0"
          -> Bundle-SymbolicName: org.jboss.tools.livereload.core; bundle-version="1.5.1.v20170822-1705"; singleton:="true"
             org.jboss.tools.livereload.core [1082]
               Unresolved requirement: Require-Bundle: org.eclipse.jetty.websocket.servlet; bundle-version="[9.4.0,9.5.0)"
                 -> Bundle-SymbolicName: org.eclipse.jetty.websocket.servlet; bundle-version="9.4.8.v20171121"
                    org.eclipse.jetty.websocket.servlet [1081]
                      Unresolved requirement: Require-Capability: osgi.serviceloader; filter:="(osgi.serviceloader=org.eclipse.jetty.websocket.servlet.WebSocketServletFactory)"; cardinality:="multiple"
                        -> Provide-Capability: osgi.serviceloader; osgi.serviceloader="org.eclipse.jetty.websocket.servlet.WebSocketServletFactory"
                           org.eclipse.jetty.websocket.server [1080]
                             Unresolved requirement: Import-Package: org.eclipse.jetty.websocket.servlet; version="[9.4.8,9.4.9)"
                               -> Export-Package: org.eclipse.jetty.websocket.servlet; bundle-symbolic-name="org.eclipse.jetty.websocket.servlet"; bundle-version="9.4.8.v20171121"; version="9.4.8"
                             Unresolved requirement: Require-Capability: osgi.extender; filter:="(osgi.extender=osgi.serviceloader.registrar)"
                               -> Provide-Capability: osgi.extender; osgi.extender="osgi.serviceloader.registrar"; version:Version="1.0.0"
                                  org.apache.aries.spifly.dynamic.bundle [1073]
                                    No resolution report for the bundle.                Unresolved requirement: Require-Capability: osgi.extender; filter:="(osgi.extender=osgi.serviceloader.processor)"
                        -> Provide-Capability: osgi.extender; osgi.extender="osgi.serviceloader.processor"; version:Version="1.0.0"
               Unresolved requirement: Require-Bundle: org.eclipse.jetty.websocket.server; bundle-version="[9.4.0,9.5.0)"
                 -> Bundle-SymbolicName: org.eclipse.jetty.websocket.server; bundle-version="9.4.8.v20171121"
               Unresolved requirement: Require-Bundle: org.apache.aries.spifly.dynamic.bundle; bundle-version="1.0.2"
                 -> Bundle-SymbolicName: org.apache.aries.spifly.dynamic.bundle; bundle-version="1.0.2"
        Bundle was not resolved because of a uses contraint violation.
        org.osgi.service.resolver.ResolutionException: Uses constraint violation. Unable to resolve resource org.apache.aries.spifly.dynamic.bundle [osgi.identity; osgi.identity="org.apache.aries.spifly.dynamic.bundle"; type="osgi.bundle"; version:Version="1.0.2"] because it is exposed to package 'org.objectweb.asm' from resources org.objectweb.asm [osgi.identity; type="osgi.bundle"; version:Version="5.0.1.v201404251740"; osgi.identity="org.objectweb.asm"] and org.objectweb.asm [osgi.identity; type="osgi.bundle"; version:Version="6.0.0.v20170929-1901"; osgi.identity="org.objectweb.asm"] via two dependency chains.
      
      Chain 1:
        org.apache.aries.spifly.dynamic.bundle [osgi.identity; osgi.identity="org.apache.aries.spifly.dynamic.bundle"; type="osgi.bundle"; version:Version="1.0.2"]
          import: (&(osgi.wiring.package=org.objectweb.asm)(&(version>=5.0.0)(!(version>=6.0.0))))
           |
          export: osgi.wiring.package: org.objectweb.asm
        org.objectweb.asm [osgi.identity; type="osgi.bundle"; version:Version="5.0.1.v201404251740"; osgi.identity="org.objectweb.asm"]
      
      Chain 2:
        org.apache.aries.spifly.dynamic.bundle [osgi.identity; osgi.identity="org.apache.aries.spifly.dynamic.bundle"; type="osgi.bundle"; version:Version="1.0.2"]
          import: (&(osgi.wiring.package=org.objectweb.asm.commons)(&(version>=5.0.0)(!(version>=6.0.0))))
           |
          export: osgi.wiring.package=org.objectweb.asm.commons; uses:=org.objectweb.asm
        org.objectweb.asm.commons [osgi.identity; osgi.identity="org.objectweb.asm.commons"; type="osgi.bundle"; version:Version="5.0.1.v201404251740"]
          import: (osgi.wiring.package=org.objectweb.asm)
           |
          export: osgi.wiring.package: org.objectweb.asm
        org.objectweb.asm [osgi.identity; type="osgi.bundle"; version:Version="6.0.0.v20170929-1901"; osgi.identity="org.objectweb.asm"]
      	at org.eclipse.osgi.container.Module.start(Module.java:444)
      	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1682)
      	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1661)
      	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1624)
      	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1555)
      	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
      	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
      	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
      

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  nickboldt Nick Boldt
                  Reporter:
                  mmalina Martin Malina
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  4 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: