Uploaded image for project: 'Tools (JBoss Tools)'
  1. Tools (JBoss Tools)
  2. JBIDE-24571

Remediation screen during installation of JBT into Eclipse JEE RC3

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Cannot Reproduce
    • 4.5.0.AM1
    • 4.5.0.AM1
    • build
    • None

    Description

      I tried to install JBT (Abridged + Additional JBoss Tools) to Eclipse JEE RC3 and I got Remediation Page with this error message:

      Your original request has been modified.
        "JavaScript Development Tools" is already installed, so an update will be performed instead.
      Cannot complete the install because of a conflicting dependency.
        Software being installed: JavaScript Development Tools 2.1.0.v201706011953 (org.eclipse.wst.jsdt.feature.feature.group 2.1.0.v201706011953)
        Software currently installed: Eclipse Web Developer Tools 3.9.0.v201706011851 (org.eclipse.wst.web_ui.feature.feature.group 3.9.0.v201706011851)
        Only one of the following can be installed at once: 
          JavaScript Development Tools 2.0.0.v201603171403 (org.eclipse.wst.jsdt.feature.feature.jar 2.0.0.v201603171403)
          JavaScript Development Tools 2.1.0.v201706011953 (org.eclipse.wst.jsdt.feature.feature.jar 2.1.0.v201706011953)
          JavaScript Development Tools 1.6.201.v201512010225 (org.eclipse.wst.jsdt.feature.feature.jar 1.6.201.v201512010225)
          JavaScript Development Tools 2.0.0.v201605311817 (org.eclipse.wst.jsdt.feature.feature.jar 2.0.0.v201605311817)
          JavaScript Development Tools 2.0.0.v201604300029 (org.eclipse.wst.jsdt.feature.feature.jar 2.0.0.v201604300029)
          JavaScript Development Tools 2.0.0.v201608301904 (org.eclipse.wst.jsdt.feature.feature.jar 2.0.0.v201608301904)
          JavaScript Development Tools 1.6.201.v201601262245 (org.eclipse.wst.jsdt.feature.feature.jar 1.6.201.v201601262245)
          JavaScript Development Tools 2.1.0.v201705091354 (org.eclipse.wst.jsdt.feature.feature.jar 2.1.0.v201705091354)
        Cannot satisfy dependency:
          From: JavaScript Development Tools 2.1.0.v201705091354 (org.eclipse.wst.jsdt.feature.feature.group 2.1.0.v201705091354)
          To: org.eclipse.wst.jsdt.feature.feature.jar [2.1.0.v201705091354]
        Cannot satisfy dependency:
          From: JavaScript Development Tools 2.1.0.v201706011953 (org.eclipse.wst.jsdt.feature.feature.group 2.1.0.v201706011953)
          To: org.eclipse.wst.jsdt.feature.feature.jar [2.1.0.v201706011953]
        Cannot satisfy dependency:
          From: Eclipse Web Developer Tools 3.9.0.v201706011851 (org.eclipse.wst.web_ui.feature.feature.group 3.9.0.v201706011851)
          To: org.eclipse.wst.jsdt.feature.feature.group [2.1.0.v201705091354]
      

      JBDS can be installed without problems because BYOE doesn't include JavaScript Development Tools.

      I see that Eclipse RC4 has been released but I can't find Eclipse JEE RC4 package, so I have tried to install JBT/JBDS into Eclipse SDK platform RC4. Both can be installed without problems but it seems that Eclipse SDK platform doesn't contains Eclipse Web Developer Tools so this test may be irrelevant.

      Attachments

        Activity

          People

            nickboldt Nick Boldt
            lvalach_jira Lukáš Valach (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: