Uploaded image for project: 'Tools (JBoss Tools)'
  1. Tools (JBoss Tools)
  2. JBIDE-24121

Update versionwatch for devstudio 11 - document/update known multiples & report upstream problems to Eclipse CVS, Help, WST

    XMLWordPrintable

Details

    • Bug
    • Resolution: Done
    • Major
    • 4.5.0.AM1
    • 4.5.0.AM1
    • build, qa, versionwatch
    • None
    • devex #132 May 2017
    • 5

    Description

      Version Watch - Summary Report: devstudio-11.0.0.AM1
      
      Multiple version issues
      
      Feature	Problem	Reference Version(s)
      
      Plugin	Problem	Reference Version(s)
      org.slf4j.api	Multiple versions of same bundle found!	1.7.2.v20121108-1250	1.7.10.v20160921-1923
      org.apache.httpcomponents.httpcore	Multiple versions of same bundle found!	4.3.3.v201411290715	4.4.4.v20161115-1643
      org.apache.httpcomponents.httpclient	Multiple versions of same bundle found!	4.3.6.v201511171540	4.5.2.v20161115-1643
      Ignored (known issue)
      org.apache.lucene.core	Multiple versions of bundle are expected and ignored - {3.5.0,5.4.1}	3.5.0.v20120725-1805	6.1.0.v20161115-1612
      javax.wsdl	Multiple versions of bundle are expected and ignored - {1.5.1,1.6.2}	1.5.1.v201012040544	1.6.2.v201012040545
      com.jcraft.jsch	Multiple versions of bundle are expected and ignored - {0.1.50,0.1.51}	0.1.53.v201508180515	0.1.54.v20170116-1932
      org.eclipse.jdt.annotation	Multiple versions of bundle are expected and ignored - {1.1.0,2.1.0}	1.1.100.v20160418-1457	2.1.0.v20170119-1701
      org.objectweb.asm	Multiple versions of bundle are expected and ignored - {4.0.0,5.0.1}	4.0.0.v201302062210	5.0.1.v201404251740
      org.apache.commons.logging	Multiple versions of bundle are expected and ignored - {1.0.4,1.1.1}	1.0.4.v201101211617	1.1.1.v201101211721
      com.google.guava	Multiple versions of bundle are expected and ignored - 13.0.0,15.0.0	15.0.0.v201403281430	18.0.0.v20161115-1643
      
      Version decreased issues
      
      Feature	Problem	Reference Version(s)
      org.eclipse.cvs	Version 1.4.300.v20170126-1030 must be higher than 1.4.301.v20161124-1400	1.4.301.v20161124-1400
      org.eclipse.help	Version 2.2.0.v20170126-1030 must be higher than 2.2.1.v20161124-1400	2.2.1.v20161124-1400
      
      Plugin	Problem	Reference Version(s)
      org.eclipse.cvs	Version 1.4.300.v20170126-1030 must be higher than 1.4.301.v20161124-1400	1.4.301.v20161124-1400
      org.eclipse.wst.server.ui	Version 1.5.306.v201610202117 must be higher than 1.5.307.v201611072017	1.5.307.v201611072017
      
       
      7 issues found.

      Attachments

        1. Screenshot_2017-03-21_12-37-07.png
          65 kB
          Nick Boldt
        2. version-decreased.png
          119 kB
          Nick Boldt

        Issue Links

          Activity

            People

              nickboldt Nick Boldt
              nickboldt Nick Boldt
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: