Uploaded image for project: 'Tools (JBoss Tools)'
  1. Tools (JBoss Tools)
  2. JBIDE-22604

CDK server adapter stuck at starting

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Blocker
    • Resolution: Done
    • 4.4.0.Final
    • 4.4.0.Final
    • cdk, upstream
    • None
    • Hide

      The way this was fixed for CDK 2.1 and devstudio 10 means that by default, sshfs (shared folder) will not be used. There is a custom Vagrantfile with sshfs configured, but if you use it with devstudio, you will still experience this issue - cdk will not start properly in devstudio.
      If you still want to use sshfs in devstudio, there is a workaround:

      1. Start CDK with sshfs setup from CLI:

      cd components/rhel/misc/shared_folder/rhel-ose
      vagrant up
      

      2. Set up CDK in devstudio (make sure to use this Vagrantfile: components/rhel/misc/shared_folder/rhel-ose/Vagrantfile) and start it
      Devstudio will notice it's already running and so it will mark it as Started immediately, thus circumventing the whole startup which would fail in this case. You can then use the cdk environment as normally - openshift connection and docker connection will both work normally.

      Show
      The way this was fixed for CDK 2.1 and devstudio 10 means that by default, sshfs (shared folder) will not be used. There is a custom Vagrantfile with sshfs configured, but if you use it with devstudio, you will still experience this issue - cdk will not start properly in devstudio. If you still want to use sshfs in devstudio, there is a workaround: 1. Start CDK with sshfs setup from CLI: cd components/rhel/misc/shared_folder/rhel-ose vagrant up 2. Set up CDK in devstudio (make sure to use this Vagrantfile: components/rhel/misc/shared_folder/rhel-ose/Vagrantfile) and start it Devstudio will notice it's already running and so it will mark it as Started immediately, thus circumventing the whole startup which would fail in this case. You can then use the cdk environment as normally - openshift connection and docker connection will both work normally.

    Description

      I have installed the development suite using the all-in-1 installer (on 3 different windows machines now). Every time I try to start CDK using the server adapter it gets stuck on 'starting'.

      In fact the CDK does start up, openshift is running, but no connection is created + the server adapter is marked as starting and the job (starting CDK) is spinning until it hits the timeout.

      Strange thing is - stopping the job/server adapter at this point will first create the desired openshift connection and then CDK wil stop.

      Attachments

        Issue Links

          Activity

            People

              rob.stryker Rob Stryker (Inactive)
              jrichter@redhat.com Jan Richter
              Votes:
              0 Vote for this issue
              Watchers:
              10 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: