This is a follow up of
JBIDE-22431 . There are some remaining things to be fixed.
1. Alexey asked for the server adapter to be renamed to "Red Hat Container Development Kit" but it's now "Red Hat Container Development Kit Support". While it makes sense to have "Support" in the feature/plugin name, I don't think it makes sense for the server adapter type or the server name once it's created. So please drop the Support.
2. Runtime detection now uses the name of "Container Development Environment". This is inconsistent with creating the server adapter manually. Some time ago we tried to unify this - EAP now has the same names both when created via runtime detection or manually (default name). So if we really want to use the CDE thing (which I'm not a fan of, but whatever), I suggest we use this as the default name when creating a CDK adapter manually. But the adapter type should probably still be "Red Hat Container Development Kit" (no Support)