Uploaded image for project: 'Tools (JBoss Tools)'
  1. Tools (JBoss Tools)
  2. JBIDE-21307

Server Adapter: ensure oc binary that's used for rsync is v1.1.1+

    Details

      Description

      Because of https://github.com/openshift/origin/issues/6109 publishing with the server adapter (which does a oc rsync behind the scenes) only properly works with oc v1.1.1. Versions below require the user to manually

      oc login --server=<server that we publish to> --token=...
      

      We should check the version and warn if the user is using an oc that is older than this.

      the changelog of oc in v1.1.1 states the following refering to the issue:

      Support some of the global rsync flags on oc rsync for displaying progress information - not supported on all rsync backends (like tar)

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  jeffmaury Jeff MAURY
                  Reporter:
                  adietish André Dietisheim
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  5 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: