Uploaded image for project: 'Tools (JBoss Tools)'
  1. Tools (JBoss Tools)
  2. JBIDE-20349

Port forwarding wizard: can "Start All" even though no ports to forward exist

    Details

    • Steps to Reproduce:
      Hide
      1. ASSERT: make sure that you have a pod running
      2. EXEC: in OpenShift explorer: select your pod (ex. dancer-example-1-deploy) and select "Port Forwarding" from context menu.
      3. ASSERT: An error in the title area tells you that there are no ports that can be forwarded.

      Result:

      I can still hit "Start All", it's enabled even thought there are no forwardable ports
      Hitting it does no harm though, no process is started.

      Show
      ASSERT: make sure that you have a pod running EXEC: in OpenShift explorer: select your pod (ex. dancer-example-1-deploy) and select "Port Forwarding" from context menu. ASSERT: An error in the title area tells you that there are no ports that can be forwarded. Result: I can still hit "Start All", it's enabled even thought there are no forwardable ports Hitting it does no harm though, no process is started.
    • Estimated Difficulty:
      Low

      Gliffy Diagrams

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                jcantrill Jeffrey Cantrill
                Reporter:
                adietish André Dietisheim
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: