Uploaded image for project: 'Tools (JBoss Tools)'
  1. Tools (JBoss Tools)
  2. JBIDE-19753

Investigate if Arquillian works fine with Sapphire 9.0.0

    Details

      Description

      Currently JBT TP includes Sapphire 9.0.0.201408261741 (available in Eclipse Mars M6 update site).
      I just checked the latest nightly build from https://hudson.eclipse.org/sapphire/job/9.0.x/ and I see that some Sapphire API has been changed. We have compilation problems in Batch because of it.
      Sapphire is gonna be updated in Mars M7 - https://www.eclipse.org/forums/index.php/t/1066214/
      And we have to switch to the new API in Batch in JBT 4.3.0.Beta1 and update Sapphire in our TP.

      So, we also should make sure that Arquillian supports the latest Sapphire 9.0.0.x. Otherwise we will get a problem with two components (Batch and Arquillian) which depends on two incompatible versions of Sapphire.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  snjeza Snjezana Peco
                  Reporter:
                  akazakov Alexey Kazakov
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: