Uploaded image for project: 'Tools (JBoss Tools)'
  1. Tools (JBoss Tools)
  2. JBIDE-19567

Thym doesn't support JGit 4.0

    XMLWordPrintable

    Details

      Description

      Thym cannot be installed/resolved against a Mars M6 target-platform, because JGit moved to version 4.0, and Thym doesn't allow that yet.

      [INFO] [ERROR] Cannot resolve project dependencies:
      [INFO] [ERROR]   Software being installed: org.jboss.tools.aerogear.thym 1.3.0.qualifier
      [INFO] [ERROR]   Missing requirement: org.eclipse.thym.core 0.1.0.201503051642 requires 'bundle org.eclipse.jgit [3.0.0,4.0.0)' but it could not be found
      [INFO] [ERROR]   Cannot satisfy dependency: org.jboss.tools.aerogear.thym 1.3.0.qualifier depends on: bundle org.eclipse.thym.core 0.1.0
      

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              gercan Gorkem Ercan
              Reporter:
              mickael_istria Mickael Istria
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: