Uploaded image for project: 'Tools (JBoss Tools)'
  1. Tools (JBoss Tools)
  2. JBIDE-19090

jbosstools-maven-plugins requires Java 7 but compiles to Java 8 requirement?

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Done
    • 4.3.0.Alpha1
    • 4.3.0.Alpha1
    • build
    • None

    Description

      Parent pom compilation is now failing if run with JDK 7 (but works w/ JDK 8):

      [8mha:AAAAYB+LCAAAAAAAAP9b85aBtbiIQSmjNKU4P0+vJLE4u1gvPjexLDVPzxdEuhYV5Rf55ZekOlc7RKnPKH7IxMBQUcQgBdWQnJ9XnJ+TqucMoUEKGSCAEaSwAACsNFCqYAAAAA==
      
      [ERROR] Failed to execute goal org.jboss.tools.tycho-plugins:repository-utils:0.22.1-SNAPSHOT:create-full-site (generate-full-site) on project 
      parent: Execution generate-full-site of goal org.jboss.tools.tycho-plugins:repository-utils:0.22.1-SNAPSHOT:create-full-site failed: An API 
      incompatibility was encountered while executing org.jboss.tools.tycho-plugins:repository-utils:0.22.1-SNAPSHOT:create-full-site: 
      java.lang.UnsupportedClassVersionError: org/json/JSONObject : Unsupported major.minor version 52.0
      

      Attachments

        Issue Links

          Activity

            People

              nickboldt Nick Boldt
              nickboldt Nick Boldt
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: