Uploaded image for project: 'Tools (JBoss Tools)'
  1. Tools (JBoss Tools)
  2. JBIDE-18750

Make CDI validation messages dependent on version

    XMLWordPrintable

    Details

      Description

      All cdi validation messages in our tool now reference JSR-299, which is CDI 1.0. Validation of CDI 1.1 and 1.2 project should reference JSR-346, besides numbers of sections for many messages are changed. Even if in most cases wording of a message may remain the same, the necessity to provide relevant references requires separating messages for each version. That will also let change wording as needed.
      The proposed solution to the task is such that in cases when a validation rule logic is the same through several versions, its implementation will not be affected other than by replacing MY_MESSAGE by MY_MESSAGE[versionIndex].

        Attachments

        1. cdi10.png
          cdi10.png
          59 kB
        2. CDI12.png
          CDI12.png
          58 kB

          Activity

            People

            Assignee:
            scabanovich Viacheslav Kabanovich (Inactive)
            Reporter:
            scabanovich Viacheslav Kabanovich (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: