Uploaded image for project: 'Tools (JBoss Tools)'
  1. Tools (JBoss Tools)
  2. JBIDE-18452

XULRunner 1.9 is not supported for linux with GTK3, WIndows and Mac OS X 64-bit

    XMLWordPrintable

Details

    • Provide Visual Page Editor features for JSF on all supported platforms
    • Done

    Description

      Current version of VPE provides full functionality (JSF and HTML4/HTML5 preview/editing) only on 32 bit Windows and Mac OS X.

      Full functionality on Linux with SWT GTK2 with limitations. XULRunner based VPE and WebKit based HTML5 preview cannot be used at the same time because of libraries conflicts.
      Eclipse with SWT/GTK 2 can use only XULRunner base VPE for JSF and HTML Preview without full HTM5 support, or WebKit based preview with full HTML5 support, but without JSF visual editing.
      Eclipse with SWT/GTK3 can use only WebKit based preview implementation.

      Windows 64-bit has XULRunner feature that can be installed, but it is not officially supported yet, so only HTML preview based on IE is supported by default.

      Mac OS 64 bit is not supported.

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              nivologd@gmail.com Denis Golovin (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: