Details

    • Sub-task
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Done
    • 4.1.1.Alpha1
    • 4.2.0.Alpha1
    • cdi
    • None

    Description

      I moved to WildFly (and therefore to Weld 2.0.CR1 resp CDI 1.1). I'm getting warnings about wrong dependency injection of these classes:

      • HttpSession
      • HttpServletRequest

      But the CDI 1.1 spec allows them to be injected (and my web app works fine).

      I'll attach a stacktrace to illustrate the wrong warnings

      Attachments

        Issue Links

          Activity

            People

              scabanovich Viacheslav Kabanovich (Inactive)
              juergen.zimmermann Juergen Zimmermann (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: