Uploaded image for project: 'Tools (JBoss Tools)'
  1. Tools (JBoss Tools)
  2. JBIDE-13639

remove struts tests from integration-tests update site

    Details

      Description

      [ERROR] Cannot resolve project dependencies:
      [ERROR]   Software being installed: org.jboss.tools.struts.ui.bot.test 4.0.0.qualifier
      [ERROR]   Missing requirement: org.jboss.tools.struts.ui.bot.test 4.0.0.qualifier requires 'bundle org.jboss.tools.struts.ui 3.1.0' but it could not be found
      [ERROR] 
      [ERROR] Internal error: java.lang.RuntimeException: "No solution found because the problem is unsatisfiable.": ["Unable to satisfy dependency from org.jboss.tools.struts.ui.bot.test 4.0.0.qualifier to bundle org.jboss.tools.struts.ui 3.1.0.", "No solution found because the problem is unsatisfiable."] -> [Help 1]
      

      This is failing because struts has been removed from the upstream sites (it's been removed from JBT4.1/JBDS 7). So, need to also remove it from your integration tests site's category.xml file [1].

      [1] https://github.com/jbosstools/jbosstools-integration-tests/blob/master/site/category.xml

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  mmalina Martin Malina
                  Reporter:
                  nickboldt Nick Boldt
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  4 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: