Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 3.3.0.Final
    • Fix Version/s: 3.3.x, 4.0.x
    • Component/s: openshift
    • Labels:
      None
    • Steps to Reproduce:
      Hide
      1. ASSERT: make sure you have some OpenShift user listed in the OpenShift Explorer, make sure it's password is stored to the Eclipse secure storage
      2. EXEC: launch the OpenShift Application wizard and create some application
      3. ASSERT: picking Show in -> Web Browser on the (freshly created) server adapter is popping up some browser and shows you your application
      4. ASSERT: make sure you dont have the OpenShift Explorer visible, select some other view in the bottom stack pane
      5. EXEC: restart Eclipse
      6. EXEC: get to the Servers view and pick Show in -> Web Browser

      Result:
      nothing happens, no browser is opened.

      Show
      ASSERT: make sure you have some OpenShift user listed in the OpenShift Explorer , make sure it's password is stored to the Eclipse secure storage EXEC: launch the OpenShift Application wizard and create some application ASSERT: picking Show in -> Web Browser on the (freshly created) server adapter is popping up some browser and shows you your application ASSERT: make sure you dont have the OpenShift Explorer visible, select some other view in the bottom stack pane EXEC: restart Eclipse EXEC: get to the Servers view and pick Show in -> Web Browser Result: nothing happens, no browser is opened.
    • Workaround Description:
      Hide

      switch to the OpenShift Explorer, refresh it so that you get asked to provide the eclipse secure storage password and get back to the adapter. The browser will then get opened.

      Show
      switch to the OpenShift Explorer , refresh it so that you get asked to provide the eclipse secure storage password and get back to the adapter. The browser will then get opened.

      Description

      If you restart eclipse, so that the user is not accessible - you'd have to provide the eclipse secure storage before being able to list a users applications - Show in -> Web Browser on the server adapter for an app does nothing (not browser is opened).

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                rob.stryker Rob Stryker
                Reporter:
                adietish André Dietisheim
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: