Uploaded image for project: 'Tools (JBoss Tools)'
  1. Tools (JBoss Tools)
  2. JBIDE-12249

A lot of failures to install from marketplace.eclipse.org

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Done
    • Affects Version/s: 3.3.0.Final
    • Fix Version/s: 3.3.2.Final
    • Component/s: build, qa
    • Labels:
      None

      Description

      It appears that most installations of JBT from marketplace concludes in an error:

      See: http://marketplace.eclipse.org/content/jboss-tools-indigo/error_reports

      Some of the most frequent errors:

      Cannot satisfy dependency: From: JBoss JAX-RS Tooling (UI) 1.2.2.v20120605-1934-H134-CR1 (org.jboss.tools.ws.jaxrs.ui 1.2.2.v20120605-1934-H134-CR1) To: bundle org.eclipse.debug.ui 3.7.101

      -> JaxRs depends on 3.7.1 ? Install from 3.7.0 or <.

      JBoss Maven Integration 1.3.0.v20120613-2141-H115-Final (org.jboss.tools.maven.ui 1.3.0.v20120613-2141-H115-Final) To: bundle org.eclipse.compare 3.5.202

      -> Maven depends on 3.7.2 ?

      Cannot satisfy dependency: From: OpenShift UI 2.3.0.v20120613-1951-H135-Final (org.jboss.tools.openshift.express.ui 2.3.0.v20120613-1951-H135-Final) To: bundle org.eclipse.egit.ui [1.0.0,2.0.0)

      -> People who don't have EGit. EGit is not part of our site.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  nickboldt Nick Boldt
                  Reporter:
                  mickael_istria Mickael Istria
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  6 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: